Submitted by fahmiidris_ in golang

Materi GOPATH, import dan package

saya lagi di materi import dan package (masih menggunakan gopath), saat import package helper, harus nya dia nyari ke gopath, tapi saat saya run saya mendapatkan error seperti pada title postinagan ini, yang mana dia nyari package nya itu goroot, setelah bertanya kesana kemari, ada yang memberi tahu bahwa pada go 1.17.1 itu sudah auto/default nya sudah harus pakai go mod (golang modules).

atau bisa mematikan go mod nya dengan cara menjalankan perintah berikut

export GO111MODULE="off"

Apakah disini teman2 ada yg mengalami hal yang sama? apakah benar?

Mohon koreksi jika salah.

−1

Comments

You must log in or register to comment.

There's nothing here…